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1 Motion - Axis Configuration 1 - Hardware

1.1 Motion Control

To control one or more axes from the NJ controller, it is necessary to associate the project with the
hardware information present in the EtherCAT network (machine network).

To do so, when starting the programming of the Motion Control module, we must set up the system
so that it knows what it is controlling.

1.2 EtherCAT Network

To obtain the EtherCAT network automatically:

¢ In the Multiview Explorer window, under Configurations and Setup > EtherCAT, double-
click.

Multiview Explorer

-1
[nws [v] “

V¥ Configurations and Setup

W » = CPU/Expansion Rackss "5 EtherCAT
L

B <& VOMap
W ¥V 2 Controller Setup
] L[} Operation Settings
| L&f Built-in EtherNet/IP Port Settings
[ V & Motion Control Setup
L &+ Axis Settings
L # Axes Group Settings
¢’ Cam Data Settings
[> Event Settings
W, Task Settings
B4 Data Trace Settings

rogramming

- AN ENEEN

v

Figure 1. Multiview Explorer window

e The workspace will display the EtherCAT network diagram.

e Initially, only the NJ controller appears in the network. To scan the network, switch to Online
mode.

dAu@m2 AR | R|[BN L5 %m0

&8 EtherCAT X Online |
Node Address Network configuration
Master
Master

Figure 2. Scan network in online mode
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¢ Right-click on the NJ controller and select Compare and Merge with Actual Network
Configuration.

¢t EtherCAT X

Node Address Network configuration
Master
Master

Write Slave Node Address
Compare and Merge with Actual Network i
Get Slave Serial Numbers

Figure 3. Compare and Merge with Actual Network Configuration

e The left side shows the project data, and the right shows the live network configuration.

 Compare and Me j g
Node Address Network configuration on Sysmac Studio  Node address Actual network confiquration Sysmac Studio Comparison result | Actual network configuration |Lower Configuration
Master ) ‘ ; - =0
Master = “ Master Master | Matched d I Master | —
1 l R88D-KNO1H-ECT Rev:2.1 || - | Added | 1: R88D-KNO1H-ECT Rev:2.1 |
2 I R88D-KNO1H-ECT Revi2.1 || —- | Added | 2 : R88D-KNO1H-ECT Rev:2.1 |
I | 4 Apply actual network configuration |
Some slaves such as Power Supply Units are not included in the actual network confiquration.
Close

Figure 4. Left side shows the project data and the right shows the live network configuration

¢ Click Apply actual network configuration to incorporate the network into the project.

Do you want to apply the actual network configuration to the network configuration on Sysmac Studio?

| Apply || Cancel |

¢ Confirm when prompted and click Close to finalize.
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Node Address N o ’
= e
Master
1 1 -I-l E001 Maste
-3 g [ R88D-KNO1H-ECT Rev:2.1 Model name Master
2 2 _I_' E002 Product name Master
i R88D-KNO1H-ECT Rev:2.1 Number of Slaves 2
PDO Communications Cycle 1000 us|
Reference Clock Not exist
Total Cable Length 1000 m)
Fail-soft Operation Setting Fail-soft operation
Wait Time for Slave Startup 30 E
PDO communications timeout detection count 2 times|
Revision Check Method Setting <= Actual device
Serial Number Check Method No check
DC Synchronous Correction Disable slave monitoring option
Device name
Set a name for the master.

Figure 5. Project network configuration

1.3 CPU BUS

To configure the CPU/bus network, use the same approach.

¢ Go to Configurations and Setup > CPU/Expansion Racks.

Multiview Explorer

-1
[rus [v] “

Vv Configurations and Setup.
B > 7 EtherCAT

o>

W V== CPURack

| | L 0 Power Supply : NJ-Px3001
| LAl CPU: NJ501-1500

m L g Units

B & VOMap

W » 3 Controller Setup

W » & Motion Control Setup
B ¢ CamData Settings

Bl = EventSettings

B ™ TaskSettings

M 4 Data Trace Settings

» Programming

Figure 6. CPU/Expansion Racks

e If there are modules on the bus, right-click and select Compare and Merge with Actual Unit
Configuration to apply it to the project.
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Show Model/Unit Name

Get Serial Numbers of All NX Units
. Compare and Merge with Actual Unit Configuration
Compare operation settings of all NX Units

Restart for NX Bus / NX Unit

Figure 7. Compare and Merge with Actual Unit Configuration

1.4 System Setup - Drive Configuration

e Based on the updated project, click: Project > Rebuild Controller > Synchronize >
Transfer to Controller.

¢ Right-click on the corresponding servo drive node and select Online.

Multiview Explorer ~ I

Node Address|Network (oniﬁ‘gur.‘ailon
new_Controller_0 v [

: | Master
A Configurations and Setup C E001
V & EtherCAT I RE88D-1SNO1
E002
Ve Setup and Tuning R88D-1SNOZ

L= Parameters

Troubleshooting
LE FFT

% Status Monitor
L B4 Data Trace Settings

¥ (© Node2 : R88D-1SNO1H-ECT (E002) : Offlji Moter and Encoder
L= Parameters Test Run
LB FFT Damping Control

L F4 Data Trace Settings Initialize

» =i CPU/Expansion Racks Properties

Ma
£ Print

troller Setup m————————
tion Control Setup o
m Data Settings
2 Gy Direct Connection (USB)
®, Task Settings
Data Trace Settings
g Programming

Figure 8. Servo drive node and Online mode selection

e Then, right-click Node 1 > Parameters and choose Setup and Tuning.
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A4 Configurations and Setup
EtherCAT
_ No
V =5 CPU/Exg§ imadancthdondond
L=w CPU Troubleshooting

I/O Map  Status Monitor

&
» [ Controll  Motor and Encoder

V & Motion ' Tegt Run
L {4 Axis

Damping Control
L ¥ Axes

Initialize
¢/ Cam Dat

> Event Se
¥, Task Set Print
F4 Data Tra

Properties

Figure 9. Setup and Tuning selection

A configuration and tuning window opens.

Setup and Tuning Portal

You can do Quick Parameter Setup, 1/O Monitoring and Tuning easily.

¥ Quick Parameter Setup and I/O Monitor
Quick Parameter Setup and I/O Monitor

Setup basic parameters quickly and monitor /O signals.

¥ Tuning

Please choose the type of tuning you want to perform:

Easy Tuning Advanced Tuning Manual Tuning

Tune based on simulating the system's
response in frequency and time domains.
Tune based on simple steps. Tune based on setting the machine rigidity.
Ensure that Inertia Ratio and Viscous Friction
Coefficient are correctly set.

Figure 10. Setup and Tuning selection window

Click Quick Parameter Setup and I/0 Monitor to open the Sysmac Studio wizard.

( Setup and Tuning ﬂ‘

Caution!

A Be sure to carefully read the operation manual before executing this function. Special care
must be taken for the following.

To avoid unexpected motor operation, take appropriate precautions and check the newly set
parameters for proper execution before using them.

Operation will be started. Are you sure you want to start the operation?

Yes No

Figure 11. Quick Parameter Setup and 1/0 Monitor
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e Awarning appears indicating that the configuration might affect machine behavior.

e Confirm to proceed.
Step 1: Motor and Encoder Configuration

e The window will display motor parameters.

Motor and Encoder setting ) » B

~Connecting with OMRON Controllers

~Configuration

Recommended settings ) Use @ Do not use Operation Direction

Jogging
~Phase Loss Detection (4320.02 hex "Main Circuit Power Supply - Phase Loss Detection Enable’) —M———————————————

Target Speed
© Enabled @ Disabled e
Transfer To Drive
Acceleration/Deceleration Time

50 : ms
How to Use Absolute Encoder (4510.01 hex ‘Operation Selection when Using Absolute Encoder’)

@ Use as absolute encoder
© Use as incremental encoder

@ Use as absolute encoder but ignore multi-rotation counter overflow 0 shaft revolutions

Transfer To Dnive Launch Motor and Encoder view Number of Cycles

~Motor Rotation (3000.01 hex 'Motor Rotation Direction Setting’)
@ CW (Clockwise) O CCW (Counterclockwise)

Transfer To Drive
Apply

Motion —

Actual Current Position

_a Command Unit

Actual Current Speed

rpm

Servo ON

Back to Portal

Figure 12. Quick Parameter Setup and 1/O Monitor

e Confirm each setting and click Transfer to Drive.

e After transferring, Sysmac Studio will prompt to restart the drive. Click Yes.

r

~

Quick Parameter Setup

Restart the drive to complete the operation.

Do you want to restart the drive now?

Yes No

Figure 13. Asking for restart the drive
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Step 2: Input Configuration

e Select input configuration and click Transfer to Drive.

Input Signals setting p

Rpa Saorets ~Configuration —M8MM W
Signal active  Physical .

condition signal status Operat{on Direction

: Jogging

® Hish e

QO Low Target Speed

® High OFF O pm

O Low

@ High 56 y

O Low 5 ) 50 ,

Acceleration/Deceleration Time
None

Home Proximity Input - Port Selec g t‘lgh Step Distance [
ow

5 0 Command Unit
Wonirinpat T-PortSaedionpp v O High

® Low 0 shaft revolutions

= . = © High
Monitor Input 2 - Port Selection (P @ Low ! Number of Cycles

Extemal Laich lnput T=PortSelea v O High 2100 o

@ Low

- 7 © High
External Latch Input 2 - Port Selec @ Low

Dwell Time

Apply

Motion
Actual Current Position

2074489481 RETNTIELT RVGT

Actual Current Speed

Return to Factory Setting  Transfer To Drive

Back to Portal < Back

Figure 14. Selecting input configuration

e Then click Next.
Step 3: Output Configuration

e Select output configuration, click Transfer to Drive, then click Finish.

10
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Output Signals setting

~Output Signals

~ Configuration

Signal active  Physical

Operation Direction
condition signal status

Jogging
. " © High 1
OUT1 Servo Ready Output - Port Selectic v @ Low OFF o Target Speed

EDM+ S pm
OUT2 Remote Output 1 - Port Selection v O High OFF Z:;, ~

@ Low i 2
WS SF1- OIS Acceleration/Deceleration Time
OUT3 Remote Output 2 - Port Selection v O Hig OFF SF2+ 2 'Y e
@ Low SF2- 'S
SFB
JERR+ SER. Step Distance B
0 Command Unit
0 shaft revolutions
Number of Cycles
0

Dwell Time

Actual Current Position

2074489481 RETUTHELTRVLT

Actual Current Speed

pm

Servo ON

Return to Factory Setting  Transfer To Drive

Back to Portal Finish

Figure 15. Output Configuration

e After configuring the first servo drive, switch Node 1 to Offline.

A4 Configurations and Setup
¥V & EtherCAT
>0 88 nline.
» (© Node2 : R88D-1SNO1H-ECT (E002) : Offline  Setup and Tuning
V¥V =1 CPU/Expansion Racks
L == CPU Rack
«* /O Map
A Controller Setup

You can do Quick

Troubleshooting
Status Monitor
Motor and Encoder

5 Test Run
L% Operation Settings

Lg# Built-in EtherNet/IP Port Settings
L I® Built-in /O Settings
L [E Option Board Settings Properties

Damping Control

Initialize

L #¥ Memory Settings Print

1 Motion Control Setup

¢’ Cam Data Settings

> Event Settings

¥, Task Settings Direct Connection (USB)

Figure 16. Configuring the first servo drive and switch Node 1 to Offline

¢ Repeat the process for the second node.

11
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1.5 Axis Configuration

After validating the EtherCAT network and configuring the drives, the axes can be defined.
¢ Go to Configurations and Setup > Motion Control Setup > Axis Settings.

¢ Right-click and select Add > Axis Settings twice (for two axes).

Con ions and Setu
W » &E EtherCAT
B » = CPU/Expansion Racks
B & VOMap
Il » = Controller Setup
™ ¥ & Motion Control Setup

L ¥ Axes Group Settings
¢’ Cam Data Settings
[> Event Settings MC Monitor Table...

&, Task Settings Axis Setting Table
£+ Data Trace Settings

> P

H Fitter

Figure 17. Axis definitions

e Example names:
o MC_Axis000 (0) — renamed to Axis1 — Conveyor
o MC_Axis001 (1) — renamed to Axis2 — Disk

12
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[nus [+] “

¥ Configurations and Setup ~
W > & EtherCAT
Il » = CPU/Expansion Racks
W < VOMap
W » 3 Controller Setup
W V #& Motion Control Setup

| | L4 MC_Axis000 (0) «. 1
L 3% MC_Axis001 (1)« 2
L #% Axes Group Settings
¢’ Cam Data Settings
[> Event Settings
®, Task Settings
4 Data Trace Settings

| |
| |
B
| |
| |
| | v
B Fitter

Figure 18. Axis name definitions

¢ Right-click on each axis to rename them appropriately.

¢ Double-click Axis1 and assign Node 1 as the output device:
o Axis Use: Used Axis
o Axis Type: Servo Axis
o Output Device: Node 1 R88D-KNO1H-ECT (E001)

¢ Repeat for Axis2 using Node 2.

e Then execute:

o Project > Rebuild Controller > Online > Synchronize > Transfer to Controller

[rus [ws

¥ Configuratons and Setup ¥ Configurations and Stup.
W > 5 EtherCAT W > & EtherCAT
W » = CPU/Expansion Racks W » = CPU/Expansion Racks
B & UOMap B & UOMsp

W » 2 Controller Setup
W V & Motion Control Setup
BV & Axis Settings

W » T Controller Setup
Il V £ Motion Control Setup
WV & Axis Settings

= Edi
L MC_Axis001 (1)

| | ! o [ | (3 MC_AxiSOOl-(l) o
= vl =
B > EventSettings Delete Il > EventSettings Delete
B onens B s
m &= Dﬂ.ta dreceocting: Start MC Test Run > .P S Dﬂ_‘ﬂ Jiocectngs Start MC Test Run
; %i!ur Stop MC Test Run .';gm‘_ Stop MC Test Run ) |

~
. . Axis Basic Settings

Axis number |0
o Axis use <
HH Axis type 2

Feedback control

Input device 1 <Not assigned>
@ Inputdevice 2 [ENotassneds
Input device 3 <Not assigned>

FEE

o

Output device 1 Node : 1 R88D-KNO1H-ECT(E001] &
Output device 2 :
’E‘ Outputdevice 3 [<Notassigned> ] Encoder axis
» Detailed Settings Virtual servo axis
v Virtual encoder axis

13
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. . Axis Basic Settings
Axis number 1
s Axis use N
Frped Axis type
Feedback control
Input device 1
Input device 2 s
vl i Servoaxis |
Output dev;ce L Node : 2 R88D-KNO1H-ECT(E002) I3 Axis type
Output device2  [<Notassigned> [w] ins
Output device 3 <Not assigned> | ¥ Encoder axis
» Detailed Settings Virtual servo axis
Virtual encoder axis
Check All Program F7 T
Build Controller F8 . s B P I

Computer: Data Name

EtherCAT Master Settings
WEtherCAT Slave Settings
Nodel : R88D-KNO1H-ECT (E001
Node2 : R88D-KNO1H-ECT (E002
W CPU/Expansion Racks
VCPU Rack
Units
¥ Controller Setup
Operation Settings
Built-in EtherNet/IP Port Settings
W¥Motion Control Setup
Axis Settings
Axes Group Settings
Cam Data Settings
Event Settings
(1] Task Settings

SIMANSFANNERE A=

| RebuidController 1|

Computer: Update Date |Controller: Update Date | Controller: Data Name

28-09-2016 15:57:33
28-09-2016 15:57:33
8 16 12:07:11
28 2016 12:07:11
28-09-2016 15:57:33
10-08-2016 15:23:00
10-08-2016 15:23:00
10-08-2016 15:23:00
20-09-2016 16:10:35
20-09-2016 16:10:35
28-09-2016 15:57:33
28-09-2016 15:57:33
20-09-2016 16:10:37
08-08-2016 14:39:41
20-09-2016 16:10:35
28-09-2016 15:57:33

28-09-2016 12:07:12
28-09-2016 12:07:12

28-09-2016 12:07:12
10-08-2016 15:23:00
10-08-2016 15:23:00
10-08-2016 15:23:00
20-09-2016 16:10:35
20-09-2016 16:10:35
28-09-2016 12:07:12
20-09-2016 16:10:36
20-09-2016 16:10:37
08-08-2016 14:39:41
20-09-2016 16:10:35
28-09-2016 12:07:12

EtherCAT Master Settings
WEtherCAT Slave Settings

VW CPU/Expansion Racks
VCPU Rack
Units
¥ Controller Setup
Operation Settings
Built-in EtherNet/IP Port Settings
V¥ Motion Control Setup
Axis Settings
Axes Group Settings
Cam Data Settings
Event Settings
Task Settings

w(.":‘,:"-;x ed |

O Clear the present values of variables with Retain attribute (Valid for Transfer to Controller).

Legend:'SynchronizedTVODifferent“’! Exists o

[ Do not transfer the program source (Valid for Transfer to Controller). All data will be re-transferred when this option is changed.

Do not transfer the following. (All items are not transferred.)
- CJ-series Special Unit parameters and EtherCAT slave backup parameters.
- Slave Terminal Unit operation settings and NX Unit application data.

Do not transfer the EtherNet/IP connection settings (i.e., tag data link settings).

l

4 | Transfer To Controller || Transfer From Controller ” Recompare

laeze )

Figure 19. Final configurations

1.6 Start Motion Control (MC) Test Run
¢ Right-click on Axis1 (0) > Start MC Test Run

14
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& EtherCAT

Il » = CPU/Expansion Racks
H ¢ VOMap

W » 3 Controller Setup

Il V £ Motion Control Setup
WV & Axis Settings

Edit -

B L% Axis2 (1)
B L8 AxesGroupSettings

B ¢ Cam Data Settings Copy
M > EventSettings Delete
B ™ TaskSettings Rename

W 4 Data Trace Settings
» Programmii _
gy ™ Stop MC Test Run L
H Fitter

Figure 20. Start MC Test Run
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 Awarning will appear because the servomotor will rotate. Take precautions and confirm.

Caution!

Special care must be taken for this function because the motor rotates. Be sure to carefully
read the operation manual before executing this function. Especially, pay attention to the
following:

Confirm the safety around the moving portions.

When you press the Start operation button, the motor will actually rotate at the specified velocity.
Carefully confirm that the motor operation does not cause any danger, and then press the button.

Install an external emergency stop device.

The motors may not be stopped by the operations from the computer. Install an external emergency
stop device so that you can stop the motor immediately when required.

Perform the operation under the conditions where you can visually check the motor operation.

Perform the operation under the conditions where you can check the motor operation so that you can
immediately take appropriate actions if motor operation causes a dangerous situation.

Establish the EtherCAT communications before executing this function.

If you attempt to start the operation before establishing the EtherCAT communications, a
communications error will occur. Be sure to establish the EtherCAT communications in advance.

Cautions during operation

During the operation, only the commands from Sysmac Studio are accepted. All commands from the
CPU Unit will become invalid.

Confirm that the correct axes are set.

Before executing the operation, confirm that the axis numbers of the target axes are correct.

Operation will be started. Are you sure that you want to start the operation?

oK || Cancel

Figure 21. Start MC Test Run

15
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Test Run Interface includes:

1. Axis selection
2. Axis state and error list
3. Axis ON/OFF
4. MC tabs: Jogging, Absolute Positioning, Relative Positioning, Homing
5. Speed, distance, acceleration, etc.
6. Execute MC commands
Axis selection [Ax=T{0)Node - [+ ] 1 &
Status — \
2
Motion error list
Level Source Event Name Details
Countermeasure
and remedy
~ Reseterors
Test Run
o | 3
Drive status —
Command current position -1 pulse  Positive limit input OFF Home input
Actual current position -1 pulse  Negative limit input OFF Servo ready
Command current velocity 0 pulse/s Immediate stop input Main power
Actual current velocity 0 pulse/s Home proximity input Drive error input OFF
Latch input 1 OFF Drive warning input
Latch input 2 OFF
‘Jogging — Absolute positioning Relative positioning |Homing
Target velocity 1000000| pulse/s If you click one of the buttons below after
: e — % clicking the Apply Button, jogging will be
Acceleration 0] pulse/s*2 bertormed only while the button is held
Deceleration 0| pulse/s~2 down.
5 6 1 v
R - "
=g v
Figure 22. Test Run Interface steps
Example:
e Set the axis to ON. The button will switch to OFF.
e Under Jogging, click Apply.
e Click MC Jogging + — motor rotates counterclockwise (CCW), position increases.
.

Click MC Jogging - — motor rotates clockwise (CW), position decreases.

Axis selection . ¥ | Test Run

v | seeon |

‘Axis2(L)(Node : 2)

Status

16
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I oo |

Jogging

Target velocity 1000000/ pulse/s

Acceleration 0 pulse/s~2

Deceleration 0/ pulse/s*2

Apply

Drive status

Command current position
Actual current position
Command current velocity

Actual current velocity

Drive status

Command current position
Actual current position
Command current velocity

Actual current velocity

11482601 pulse
11464089 pulse  9OW™

1000000 pulse/s - >+

933000 pulse/s

If you click one of the buttons below after
clicking the Apply Button, jogging will be
performed only while the button is held

down.
> [

If you click one of the buttons below after
clicking the Apply Button, jogging will be
performed only while the button is held

9818601 pulse
9837055 pulse
-1000000 pulse/s
-978000 pulse/s

Figure 23. Example configuration

1.7 MC Commands

« Jogging: moves the motor in + or — direction at the defined speed.

Jogging

Target velocity
Acceleration

Deceleration

1000000 pulse/s
0/ pulse/s~2

0| pulse/s2 down.

Figure 24. Jogging

> >

e Absolute Positioning: moves motor to defined position from origin.
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Absolute positioning
Target position 10000, pyise If you click the button bglow after clicking the
1600000 Apply Button, test run will start.
i I S
L PUSsels Direction [Positive direction] » |
Acceleration 0/ pulse/sr2
Deceleration 0/ pulse/s»2 »
Jerk 0/ pulse/s3
[ Apply |

Figure 25. Absolute Positioning

¢ Relative Positioning: moves motor a defined distance from current position.

Relative positioning

Distance 10000, pylse If you click the button below after clicking the
Apply Button, test run will start.
Target velocity 1000000/ pulse/s
Acceleration 0 pulse/sa2 =3
Deceleration 0/ pulse/sA2
Jerk 0/ pulse/s3
[ Apply |

Figure 26. Relative Positioning

e Homing: defines origin, may use limits, proximity, or home sensors.

Homing
Homing is performed according to axis If you click the button below after clicking the
parameter settings on the Homing page. Apply Button, test run will start.

| Show Homing Settings |

>

| Apply Homing Settings |

Figure 27. Homing
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2 Motion - Axis Configuration 2 - Hardware

2.1 Axis Configuration — Axis1 [Conveyor]

After assigning the hardware (servo drive) to the axis via Axis Basic Settings and validating correct
operation via MC Test Run, we continue configuration via Motion Controller Setup > Axis
Settings.

Button Name Description

Set whether to use the axis, the axis type, the axis number, an input or output

Aty il Selings device, and the channel.

Set the gear ratio of the electronic gear.

Unit Conversion Settings : S
I rorsh g Set the pulses per motor rotation and the travel distance.

Set the velocity, acceleration rate, deceleration rate, torque

Cipsawiion ~elngs warning values, and other monitor parameters.

Other Operation Settings | Set the I/O for the Servo Drive.

Limit Settings Set software limits and following error limits.

Homing Settings Set the homing operation.

Position Count Settings Set Count Mode of the Controller.

Servo Drive Settings Set the Servo Drive parameters.

Axis number
Motion control Vi
Axis use Used axis
Auxis type Servo axis v
Control function Single-axis position control only v
Feedback control No control loop ¥
Input device 1 <Not assigned> v Channel
Input device 2 5 Channel
Input device 3 < g Channel
Output device 1 Node : 1 R88D-1SNOIH-ECT(EO0IL) v Channel
Output device 2 <Not assigned> ¥ Channel
Output device 3 <Not assigned> v Channel

P Detailed Settings

Figure 28. Axis Settings

2.2 Unit Conversion Settings

Unit Conversion Settings
e Configure units for Axis1 (Conveyor) in Unit Conversion Settings.
e Based on mechanical data:
o Each motor rotation moves the conveyor 110 mm
o Encoder: 23-bit — 8,388,608 pulses/rev
Settings:
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1. Working unit: mm
2. Pulses per rotation: 8,388,608

3. Distance per rotation: 110 mm

— After these values are set, the Operation Settings icon shows an error until configured.

r = radius
C = Circumference

C=2mr

Figure 29. Unit Conversion Settings

For the existing 1S servo drive / servo motor, we have:
¢ 23-bit incremental encoder;

e 3,000 rpm.
Standard Servo Motors
Servo motors 1,000-— 2,000 - 3,000 r/min

100 to 3,000 Kw

Specifications Servo Drive

Voltage Encoder Capacity 1S
230 V Absolute encoder (23 bit) |50 W R88D-1SNO1H-ECT

T‘TYT’

¥ Unit
Unit of display @ puloo mm ® um ® nm @ degree @ inch

¥ Travel Distance

Command pulse count per motor rotation RERELNEY pulse/rev --—- (1) o
© Do not use gearbox
o Work travel distance per motor rotation m mm/rev -— (2)

Reference: Unit conversion formula

_ (1) Command pulse count per motor rotation [UDINT] , 2
Number of pulses [pulse] = () Work travel distance per motor rotation [LREAL] Travel distance [Unit of display]

(1) Definition of the working unit, in this case mm

(2) Pulses per motor revolution

The motor generates 2% = 8,388,608 pulses per revolution, based on its 23-bit incremental encoder.
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(3) Distance traveled per rotation: 110 mm

(4) After defining these values, the Operation Settings icon will indicate an error.

In the next step, we must configure the Operation Settings for axis 1.

2.3 Operation Settings

Velocity calculations:

* Max Velocity:
RPM /60 =RPS
3000 /60 =50 RPS
50 RPS x 110 mm = 5,500 mm/s

 Max Jog Velocity:
10 RPS % 110 mm = 1,100 mm/s

2.4 Home Settings

e Since Axis1 controls a conveyor, homing is configured so that when executed, the current
position is reset to zero.
% Axis1 (0) =1
@}\‘ -EB- ming Setting [ Configuracdo do método de busca de origem ]
Homing Method l Método de busca J
L:‘u;' Homing method [No home proximity input/holding home input| ¥ |
HHH | Home input signal [Use external home input| v |

[ @ [ Velocity/Acceleration/Deceleration
Homing velocity 5500 mm/s Homing approach velocity 1000, mm/s
Homing acceleration 0| mm/s*2 Homing deceleration 0| mm/sA2
Homing jerk 0 mm/s*3
Others - ” o <
Os diferentes métodos tém parametros comuns configuraveis , assim como alguns
proprios, estes se forem utilizados sdo mostrados nesta secgdo.

Operation selection at positive limit input [Reverse turn/immediate stop| ¥ |
peration selection at negative limit input |Reverse turn/immediate stop| ¥ ]

Homing start direction [Positive direction| ¥ ]
Home input detection direction |Positive direction | ¥

g Home proximity signal

)
Pode-se escolher uma
grande variedade de

External home input ' Durante todo o

métodos, formatos e processo temos uma
configuragdes de representacdo grafica
origem: Método de Negative limit input do comportamento
busca, sinal de origem, que terd o eixo
direcgdo em que se durante a busca de
comega a busca, [HCIREEOTEEIEY origem, esta
direcgdo em que se vai home signal input representagao

detectar o sinal de actualiza-se em fungdo

Positive limit input

origem, das configuragdes
comportamento BN from tuming ON of ~ ———fuizzszssssseimesssssnnnsl gooneneeseesssdpmennnnnnnnes ll escolhidas,
actuar os limites de home signal input simplificando assim a

escolha do método
adequado para a
maquina.

posicionamento
(independentes) ...

“Start from positive side of
home signal input

Since

Figure 30. Homing configurations

this axis controls a conveyor, the homing method is configured as follows.

This means that when the homing instruction is executed, the current axis position is set to zero.
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il

Homing Method

1% Axisl (0)
{é{ Homing Settings
LM

Homing method [Zero position preset] ¥ |

+ 4 x
Home input signal [ [x]
Homing start direction [Positive direction| v | Operation selection at positive limit input [ [x]
Home input detection direction ' Operation selection at negative limit input | '

Home proximity signal

External home input

Positive limit input

Negative limit input

@ Velocity/Acceleration/Deceleration
Others

Figure 31. Homing configurations

2.5 Unit Conversion Settings

We must configure the units in which we want to work for axis 2 (disk). These are defined in Unit
Conversion Settings.

Based on the mechanical element driven by the servo motor of axis 2, we have the following:

90°

180° 0°/360*

270°

Working in degrees [°], we verify that for each motor revolution, the disk moves 360°.
For the servo drive / servo motor used in the Sysmac didactic bench, we have:
e 23-bit incremental encoder

e 3,000 rpm
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Document:

Specifications Servo Drive

Voltage Encoder Capacity 1S

230 V Absolute encoder (23 bit) |50 W R88D-1SNO1H-ECT

Trm‘-

¥ Unit

Unit of display @ pulse ® mm ® um & nmoo degree @ inch

¥ Travel Distance

Command pulse count per motor rotation 8388608 FNENEN

© Do not use gearbox

Work travel distance per motor rotation m degree/rev -—- (2)

Reference: Unit conversion formula

Number of pulses [pulse] =

(1) Definition of the working unit, in this case degrees [°]

(2) Pulses per motor revolution:

(1) Command pulse count per motor rotation [UDINT]
~ {2) Work travel distance per motor rotation [LREAL]

223 bits _ 8 388,608 pulses/revolution

(3) Distance traveled per revolution: 360°

(4) After setting these values, the Operation Settings icon displays an error.
In the next step, we must configure the Operation Settings for axis 2.

Mechatronics

Student’s guide —

Mechat

* Travel distance [Unit of display]

ronics Motion
Platform

2.6 Operation Settings

[frasze
~
{S‘S& Operation Settings
‘\ -
v Velocity/Acceleration/Deceleration
u*m‘:l Maximum velocity 18000/ degree/s . 1 Velocity warning value 0%
FH Start velocity 0 degree/s
Maximum jog velocity 3600 degree/s . 2
Maximum acceleration 0 degree/s*2 Acceleration warning value 0 %
6 Maximum deceleration 0 degree/s*2 Deceleration warning value 0 %
] Acceleration/deceleration over [Use rapid acceleration/deceleration (Blending is changed to Buffered)[ v |
Operation selection at Reversing [Deceleration stop] ¥ |
* v Torque
« Positive torque warning value 0 % Negative torque warning value 0 %
¥ Monitor
In-position range 10 degree In-position check time 0 ms
Actual velocity filter time constant 0 ms Zero position range 10 degree
v S >

Figure 32. Operation Settings
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velMaz [Hz| = velMazx [rpm|/60 [s];

velMaz [Hz] = 3000 [rpm|/60 [s] = 50 [Hz];
(3) Maximum Speed
18,000 °/s
velMaz [*/s] = velMax [Hz] x A8 [°]

velMax [*/s] = 50 [Hz] x 360 ["] = 18,000 [ /5]

(4) Maximum Jog Speed
3,600 °/s
velMazJog [*/s] =10 [Hz] x A6 [°]
velMaxJog [°/s| = 10 [Hz] x 360 [°] = 3,600 [ /s]

2.7 Home Settings

In the homing method configuration, we define the behaviour of the axis during the homing operation.
Since this axis controls a disk, the homing method is configured as follows.

% Axis2 (1) = [al o3

4 B

Homing Method

Homing method [Zero position preset| ¥ |
- Home input signal [ | I
- : Homing start direction | [x] Operation selection at positive limit input | [~1

Home input detection direction [ | ] Operation selection at negative limit input |

@ Home proximity signal

Z-phase input

Positive limit input

Negative limit input

@ Velocity/Acceleration/Deceleration
Others

Figure 33. Homing settings — Axis 2
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This means that when the homing instruction is executed, the current position of the axis is set to
zero.

¥ Axis2 (1) v 0O X

@ B

Homing Method

U:“:' Homing method [Zero position preset[ v |
Home input signal [ | l
Homing start direction [ | ] Operation selection at positive limit input [ | ]
) Home input detection direction [ ] Operation selection at negative limit input [ ]
@ Home proximity signal
; Z-phase input
«» Positive limit input

Negative limit input

@ Velocity/Acceleration/Deceleration
Others

Figure 34. Homing settings — Axis 2

2.8 Position Count Settings

The count mode defines how the axis position is tracked. The position count mode must be set for
the command positions of each axis. There are two count modes:

Linear Mode (Default mode)
The count mode is set to linear when an axis always moves within predefined limits that will never
be exceeded.

2 )

Figure 35. Linear mode
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. Position Count Settings

Count mode o Linear mode O Rotary mode
Modulo maximum position setting value 2147483647 | degree
Modulo minimum position setting value -2147483648| degree

Encoder type [Incremental encoder’ (v ]

Figure 36. Linear mode example

Rotary Mode
The count mode is set to rotary when an axis performs continuous or infinite motion that exceeds
the maximum or minimum value of the Position Module.

Figure 37. Rotary mode

. Position Count Settings

Count mode O Linear mode 0 Rotary mode

Modulo maximum position setting value 360 degree
Modulo minimum position setting value 0| degree
Encoder type

Figure 38. Rotary mode example

For Axis2 [Disk], this means that we will have a new position reference every 90° of rotation.

1st Rotation 2nd Rotagdo
0° 90° 180° 270° 360° 450° 540° 630° 720°
0° 90° 180° 270° 360°/0° |90° 180° 270° 360°/0°

Linear Count Mode
Rotary Count Mode

Accordingly, we apply the following configuration to Axis2 [Disk]:
Position Count Settings

1. Rotary Mode

2. Maximum position: 360°

3. Minimum position: 0°
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Then execute the following steps:
Project > Rebuild Controller > Online > Synchronize > Transfer to Controller

Run a test using MC Start Test Run and verify the differences in the position count mode.

4 Axis2 (1) Haq%~ox
!g_a.| Position Count Settings

Count mode O Linear mode @ Rotary mode 1
Modulo maximum position setting value 360| degree . 2
Modulo minimum position setting value \ 3 _~ 0| degree

Encoder type [Incremental encoder| v |

# IS ™

i
8

Figure 39. Position Count Settings
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3 Motion: Start-up — Software

After assigning the hardware (servo drive) to the axis via Axis Basic Settings and validating correct
operation via MC Test Run, we continue configuration via Motion Controller Setup > Axis
Settings.

RALMEN Cofinanciado por
L |a Unidn Europea

3.1 Start-up Procedure

To move any axis, only 3 commands are required: MC_Power, MC_Home, and MC_Move, all linked
to one of the previously created and configured axes.

Global Variables view in Programming > Data

Multiview Explorer ~a

PR

m> POUs

Il V= Data
] L& Data Types

W » B3 Tasks gl!;

Figure 40. Global variables in Programming > Data

When we access global variables via Programming > Data > Global Variables, we see that two
global variables of type _sAXIS_REF were automatically created, one for each axis.

|var| Global Variables X

‘Name Data ype Initial Value Retain Constant/ Network Publish Comment
L)

So far, we have been working with local variables. To view them:
1. Go to View

2. Open the Variable Manager
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§j My First Project Mg
. File Edit View . 1 : Project Controller Simulation Tools
Multiview Explorer Alt+1
b

4 Toolbox Alt+2
Output Tab Page Alt+3
Watch Tab Page Alt+4
Cross Reference Tab Page Alt+5
Build Tab Page Alt+6
Search and Replace Results Tab Page  Alt+7
Simulation Pane Alt+8
Differential Monitor Alt+9
Variable Table Ctrl+Shift+V
Variable Manager... .. 2
Smart Project Search Ctrl+Shift+F
Recently Closed Windows Ctrl+Shift+H
Clear Recently Closed Windows History
Zoom »
Reset Window Layout

Figure 41. Working with local variables

Switching between Global and ProgramQ Variables
To convert a local variable to global, right-click the variable and select Move Variable to Global.

Scope of Global Variables:
They are accessible from any POU (Program, FB, or FUN). To avoid unintended access, a variable
accessed by a POU should be declared as external.

[Giobal Variables [v]

[ Show Usage

Name Data Type Comment
Axisl _SAXIS_REF
Axis2 _SAXIS_REF

<

& Always on Top | Delete Unused Variables| | Update| |Close |

Figure 42. Global variables

To view the local variables associated with ProgramO:
1. Switch from Global Variables to Program0

2. If you want to change a variable from local to global, right-click the variable and select
Move Variable to Global
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|Program0
Show Usage

Internals

Name Use I/O Mapping
x_S0_Inp1
x_S0_Outl @
x_S0_Inp2
x_S0_Inp3
x_S0_Inp4
FB_SO_RS1
x_S0_Out2
x_S1_Inpl
FB_TIM_1
tim_ElapsedTime_TIME

Copy
Delete Variable

Move Variable to Global

Search

N NNN RN

Ng

[ Always on Top Delete Unused Variables| | Update| |Close |

Figure 43. Global Variables to ProgramO

Scope of Global Variables

Global variables are accessible from all POUs (Programs, Function Blocks, and Functions).

To prevent unnecessary access and avoid potential issues, access to a POU should be defined as
an external variable.

/ Global Variable

1
Poul

External

External

Variable Variable Variable

Variable

\\ 4

Figure 44. Global variables accessible from all POUs
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3.2 sAXIS_ REF Structure

Each created axis is of type _sAXIS_REF.
Using the Watch Window, we can inspect the structure of these axes.

Name Data type AT v i —SAXIS_REF CFG ¥ Drstatus ~SAXIS_REF_STA_DRV

v Adsl _sAXIS_REF MCJ//_MC_AX[0] ANo UINT ServoOn 800L
> Clg ~SAXIS.REF.CFG AEnsble  _eMC_AXIS_USE Ready 80OL
RaSale A R AxType _eMC_AXIS_TVPE MainPower | BOOL
P Status SAXIS_REF_STA NodeAddress  UINT p.oT 8oL
P> Detals SIS REDEY ExedD UINT N.OT 8OOL
» Dir _SAXIS_REF_DIR S YT e oo
» DnStatus _sAXIS_REF_STA_DRV S T o oy
> Cmd _SAXIS_REF_CMD_DATA o - il 000
RiiAct =ANS REE ACTDATA Units _eMC_UNITS Latcht 80OL
> Maulix +MC_REF_EVENT CountMode _eMC_COUNT_MODE Latch2 8OOL
PiOba CEMCRECEVENT MaxPos LREAL DrvAlarm BOOL
MinPos LREAL DrvWaming  BOOL
AXIS_REF [ wstatus  SAXISREFSTA | 1A 800L
Setup and Command Ready 8ooL GSB oot
Monitoring and Status Disabled 800L O BooL
Alarms and Warnings S BOOK L1 SO0t

Discrete 8OOL v Cmd _SAXIS_REF_CMD_DATA
Continuous BOOL Pos LREAL
Synchronized  BOOL Vel LREAL
Homing BOOL AccDec LREAL
Stopping 800L Jerk LREAL
ErrorStop 800L Ta LREAL

Coordinated BOOL V¥ Act _SAXIS_REF_ACT_DATA
¥ Details _SAXIS_REF_DET Pos LREAL
Idle BOOL Vel LREAL
InPosWaiting  BOOL Trq LREAL
Homed 80CL TimeStamp ULINT

InHome BOOL V¥ MFaultlvi _SMC_REF_EVENT
Vellimit B8OOL Active BOOL
v Or SAXIS_REF_DIR Code WORD
Posi 8OOL ¥ Obsr _sMC_REF_EVENT

Nega 80OL Active 8OOL
Code WORD

Figure 45. _sAXIS_REF Structure

3.3 Motion Basics

In Programs, add a new program in Ladder, naming it Program_Motion.
Call the initial section: Section0_MotionBasics.

=) > ot ey
V¥ Liannmiog
[nws [v] “ W VY @ Pous
» Configurations and Setup B V E Programs
v m | » [} Program0
MV @ Pous u ¥ 9 Program_Motion
5 E Progamiy o) IR e
| L # Functions Paste ST n L 8% Functions
Il L& Function Blocks n L& Function Blocks
W V= Data M V3 Data
B L3 DataTypes M LS DataTypes
n L w1 Global Variables ] L b= Global Variables
Il > B3 Tasks W » Ea Tasks

Figure 46. Section0_MotionBasics
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3.4 Task

New programs must be assigned to a Task, otherwise the controller won’t execute them.

Multiview Explorer ~

[ns [v] “

V¥V Configurations and Setup
W > 5 EtherCAT
W » = CPU/Expansion Racks
W ¢ VOMap
H » 3 Controller Setup
Il V¥ & Motion Control Setup
W V& Axis Settings
[ L Axisl (0)
|| L i# Axis2 (1)
] L ¥ Axes Group Settings
B ¢ Cam Data Settings
O
|
P

[> Event Settings

b Data Trace Settings

» Programming

Figure 47. Accessing Task Settings and creating assignments

The Task Settings window opens. Here, you can create three types of tasks:

¢ Primary task
» Priority level: 4

e Additional periodic tasks can be created and assigned a lower priority
» Priority levels: 16, 17, and 18

+ Event tasks can be configured to execute when a specific condition is met
» Priority levels: 8 and 48

[¥ asicsettings HaQByax
. ~n s .
/ / Task Settings
e | =

Task Type Task Name Period/Execution
M Priority-4 Primary Periodic Task PrimanyTask | [Ims [ ]

o [2Ia
v £ b

Figure 48. Tasks and priorities

For this example, we will use the existing primary task.
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1. Select the Program Assignment Settings tab

2. Click + to add a program to the primary task
3. Click on the drop-down list
4. Select the previously created program, Program_Motion
%, Task Settings HaqQnyox
/ /-E-‘ Program Assignment Settings
” C C C
v M PrimaryTask
Program name Initial status
E:) 1 [Program0 v| [Run w
2 L 3 7

4] :

Figure 49. Program Assignment Settings tab

3.5 MC_Power

The first step in using an axis is to power it on.

Toolbox -0
|<Search> | v H:] E]
~

Math

Motion Control n |

: m

Program Control
SD Memory Card

Selection

v EV &V BV &V kv BV

Sequence Control

To do this, use the MC_Power instruction, which can be found in the Toolbox, under the Motion
Control tab.

Whenever the prefix MC__is used in the system, it refers to Motion Control.

Objective: Power on the created axes using separate digital inputs.

Name Data Type
x_MS0_Axis1_PowerOn | BOOL '

FB_MC_Power_Axisl MC_Power
x_MS0_Axis2_PowerOn | BOOL
FB_MC_Power_Axis2 MC_Power
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3.6 MC_Power — Exercise 1

Create a program in Sysmac Studio to test the functions FB_MC_POWER to Axis 1 and axis
2

Once the programming is complete, perform the following steps:
Project > Check All Programs > Rebuild Controller > Online > Synchronize > Transfer To
Controller

After synchronizing the project with the controller, validate and verify the code operation.

3.7 MC_Home — Exercise 2

Depending on the homing method defined for each axis, the MC_Home instruction will execute the
homing operation.

In this case, when the homing instruction is executed, the current position is set to zero.
Objective: Apply the homing command to each of the axes
Naming convention:

Name Data fype
FB_MC_Power_Axis2 MC_Power
x_MSO_Axis1_Homing | BOOL
FB_MC_Home_Axisi MC_Home
x_MS0O_Axis2_Homing | BOOL
FB_MC_Home_Axis2 MC_Home

Create a program in Sysmac Studio to test the functions FB_MC_HOME to Axis 1 and axis 2

Once programming is complete, perform:
Project > Check All Programs > Rebuild Controller > Online > Synchronize > Transfer To
Controller

After synchronizing the project with the controller, validate and test the code.
Executing MC_Power for each axis and then triggering the inputs that student have created.
Note: student can verify via the Watch Window that the homing instruction is executed.

Also, verify the position values of Axis1 (Conveyor) and Axis2 (Disk) and test if different from zero,
are then reset to zero.

3.8 MC_MoveVelocity — Exercise 3

After executing MC_Power and MC_Home (if necessary), the next step is to use MC_Move to put
the axis in motion.

Objective: Apply the MC_MoveVelocity instruction to each of the axes
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Data Type

x_MS0_Axis1_MoveVel

BOOL

FB_MC_MoveVel_Axis1

MC_MoveVelocity

Ir_Axis1_MoveVel

LREAL

Ir_Axis1_Acc

LREAL

Ir_Axis1_Dcc

LREAL

FB_MC_Stop_Axis1

MC_Stop

x_MSO_Axis2_MoveVel

BOOL

FB_MC_MoveVel_Axis2

MC_MoveVelocity

Ir_Axis2_MoveVel

LREAL

Ir_Axis2_Acc

LREAL

Ir_Axis2_Dcc

LREAL

FB_MC_Stop_Axis2

MC_Stop

Objective: Analyze the motion logic applied to each axis using the MC_MoveVelocity and

MC_Stop function blocks.

1. Apply the FB MC_MoveVelocity Code to Axis1 (Conveyor)

2. Sets the motion profile with velocity, acceleration, and deceleration values.

3. Starts the conveyor when the system is powered and a start command is given.

4. Stops the axis smoothly using the MC_Stop block.

Task 1: Explain the role of each input and output in the MC_MoveVelocity block for Axis1.

Task 2: What would happen if the x_MS0_Axis1_MoveVel command were suddenly interrupted?

Justify your answer.

Apply the FB MC_MoveVelocity Code Applied to Axis2 (Disk)

5
6. Initializes the motion profile for the rotating disk.
7

Starts the motion of Axis2 based on the command input.

8. Applies deceleration and stops the disk in a controlled manner.

Task 3: What are the main differences between the way Axis1 and Axis2 are controlled?
Task 4: In what real-world situations would this type of motion control be useful for a labeling disk?

Once the programming is complete, perform the following steps:
Project > Check All Programs > Rebuild Controller > Online > Synchronize > Transfer To

Controller

After synchronizing the project with the controller, validate and verify the code operation.
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4 Motion: Exercise - Software

The goal is to create a program that controls a conveyor belt (Axis1 - Conveyor) and a label
applicator disk (Axis2 - Disk).
4.1 Exercise

To move any axis, only 3 commands are required: MC_Power, MC_Home, and MC_Move, all linked
to one of the previously created and configured axes.

Figure 50. Axis1 (Conveyor)

Figure 51. Axis 2 (Disk)

Components are transported along the conveyor, which has two sensors installed along its path.

If a component triggers sensor 1 and, after 5 seconds, does not trigger sensor 2, this means
the component is stuck at the entry zone.
In this case, the system must stop.

The conveyor runs at a speed defined in the program code, and when the detector located at the
labeling station is triggered, the conveyor must stop until the label is placed by the disk.
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Figure 52. Final exercise

4.2 Exercise 1

In Programming > Programs > Program_Motion, create a new
Section1_Machine

Multiview Explorer ~ 1

s G |

» Configurations and Setup

¥ Programming

WY @ Pous

B V& Programs

| » [~ Program0

| ¥ {4 Program_Motion

|| L 4% Section0_MotionBasics
- B L Sectionl Machine

] L & Functions

] L & Function Blocks
Il » B2 Data

W » B3 Tasks

Exercise — Motion Sequence Programming
The following logic rungs are part of a labeling system that uses two axes:
e Axis1: Conveyor

e Axis2: Labeling Disk

section named:

Student goal is to analyze, understand, and complete the motion sequence logic described below:
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Rung Descriptions

e Rung0
Activates the servos based on the digital input x_MS1_RUN.

e Rungs1/2/3
The variables X_Box1_Detection and X_Box2_Detection simulate the passage of
components past Sensor 1 and Sensor 2.
If Sensor 1 is triggered but Sensor 2 is not triggered within 5 seconds, the system must
stop by resetting the run command.

e Rung4
After Axis2 (Disk) is powered on, its homing procedure is executed.

e Rungs5/6/7
Once Axis2 has been homed, the conveyor (Axis1) starts moving until the labeling
position detector is triggered (x_Box1Mark).
At this point, the conveyor must stop to allow labeling.

Note: You will need to add 3 extra conditions to Rungs 6 and 7 (see Exercise 2).

e Rungs8/9/10/11/12
When the conveyor stops because a component is detected at the labeling position, the
disk moves from its resting position to the labeling position, waits 3 seconds, and
then returns to its home position.

4.3 Exercise 2 - Complete the Logic

Student must complete Rungs 6 and 7 to ensure that the conveyor resumes movement after the
label is applied.

e Add point 1 to Rung 6

FB_MC_MoveAbs_Disk_FromApply.Done
—{1}

1

e Add points 2 and 3 to Rung 7

FB_MC_MoveAbs_Disk_ToAppiy.Busy FB_MC_MoveAbs_Disk_FromApply.Busy
I /L 1 /1
/1 1/1

These additions must ensure that the system automatically restarts conveyor motion after the
labeling process finishes.

Once completed, test the logic in simulation and validate the expected behavior of the conveyor and
labeling disk.
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